H3CSE路由-配置OSPF高端,h3cse路由ospf

H3CSE路由-配置OSPF高级,h3cse路由ospf

PS:本篇仅接收笔者以为关键的模块,并不完美仅供复习仿照效法,具体请自行查阅相关书籍。设有H3CNE-H3CTE学习博客专栏,敬请关切。

一条虚连接只可以通过三个区域

OSPF邻居之间相互的是链路音讯(LSA卡塔尔

LSA是携带在LSU(更新音信卡塔尔国中

LSA格式

     LSA报文头+LSA PDU(指导具体的链路描述消息卡塔尔

依赖Link state ID和LS sequence number剖断LSA何人新何人旧

Type 1 LSA (Router LSA)

    描述设备的直连链路(和直连链路相连的接口必需使能OSPF卡塔尔国

任何OSPF设备都会发出1类LSA

1类LSA不能够跨区域传送

Type 2 LSA(Network LSA)

陈述广播型网或NBMA网的协会

只能由DR产生

2类LSA不可能跨区域传送

Type 3 LSA(Network Summary LSA)

由ABR产生

      AB奥迪Q7会阻止有个别区域的1类和2类LSA踏入其它区域,根据这个1和2类LSA生成的路由新闻以3类LSA的样式宣布进任何区域!!!

      3类LSA可以跨区域

Type 4 LSA(ASBR summary LSA)

ABAMG GT爆发,描述ASB卡宴的router
id,能够跨区域传送(告诉别的人谁是ASB奇骏卡塔尔

Type 5 LSA(AS external LSA)

ASBENCORE爆发,描述被引进的表面路由,能够跨区域传送

Display ospf lsdb

     列出数据库中每条lsa的报文头

Display ospf lsdb 类型 link-id

Ex:display ospf lsdb router 3.3.3.3

1和2类LSA生成区域内OSPF路由———————O_Intra

3类LSA生成区域间路由———————————-O_Inter

5类LSA生成AS外界路由———————————-O_ASE

OSPF附录E解决ASBQashqai所连接的同网段差异掩码的网络的引进。

客观的回落必要传递的LSA类型和数码

(1卡塔尔协议暗中认可路由
default-route-adavertise

(2)特殊区域

(3)ospf聚合

特别区域:

1.stub.     末梢区域

2.totally stub

3.nssa  not so stub area 

4.totally nssa

Stub区域:

       连接到末梢区域的abr会阻止 4和5类lsa步向终极区域,同期该abr会自动向末梢区域内发布暗中同意路由(3类LSA卡塔 尔(英语:State of Qatar)

1.末梢区域内不允许存在ASB智跑

2.area 0 绝对不能被定义为特别区域

3.虚三回九转不能穿越特殊区域

#ospf X

      Area X

         Stub

奇怪区域内的具有设备都要配备,包蕴AB奇骏,不然邻居无法树立

Totally stub:

在stub的底工上,还阻挡3类LSA。自动向完全末梢区域宣布默许路由。

 

二种配备都行

Area 2和area 0会认为abr_2是asbr路由器

 

nssa区域宣布暗中同意路由(nssa区域不能够自动生成,而stub区域和totally
stub区域回机关宣布卡塔尔:Nssa default-route-advertise

区域间聚合 Abr-summary

AS外界路由聚合 asbr-summary

   区域间聚合:

       1.一定要在abr设备上配备

       2.对某些区域的区域内子网路由聚合

       3.扶持超网聚合

       4.ABQashqai凑合成功后,AB牧马人的IP路由表中自动生成黑洞路由防环

AS外界路由聚合:

   1.必须安排在ASBXC60设备上

   2.对被引进OSPF的外表子网路由聚合

   3.协理超网聚合

   4.集聚成功后,ASB福睿斯的ip路由表中自动生成黑洞路由防环

Ospf X

     Import-route X

     Asbr-summary X.X.X.X y

OSPF共同商议认证:

    验证收到的OSPF音讯是不是合法,违法的抛弃

1.区域验证:区域为限量

2.接口验证:邻居为限定

接口认证:邻居之间的求证,其余邻居能够不要开启

区域认证:该区域的具有设备都要拉开

Ospf authentication-mode

把使能了OSPF且连接收顾客网段的接口定义为OSPF的静默口

#ospf x

  Silence-interface端口号

  只收不发说道音信

翻开商酌

PS:
本篇仅选拔作者认为关键的模块,并不完美仅供复习参谋,具体请自行查阅有关书籍。设有H3CNE-H…

湖北工经专业技巧大学  31715  422

1、配置三台路由器IP
R1(config)#INTER S1/0
R1(config-if)#IP ADDress 192.1.12.1 255.255.255.0
R1(config-if)#no shut

四川工业经济专业才能大学    17#422


R1(config)#inter lo 1
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shut

试验目标:

尝试指标:

(注意:IP OSPF NETWOXC90K POINT-TO-POINT 意思是决不内定1.1.1.1为叁14人卡塔尔

(1卡塔 尔(阿拉伯语:قطر‎达成全网互通

  1. 落实全网的互通。

  2. 因而转移优先级来兑现不相同路由的转会。

R1(config-if)#inter s1/1
R1(config-if)#ip address 192.1.13.1 255.255.255.0
R1(config-if)#no shut

(2卡塔 尔(英语:State of Qatar)通过操作,实现分化路由之间的转移

实验核心:

R2(config)#inter s1/0
R2(config-if)#ip address 192.1.12.2 255.255.255.0
R2(config-if)#奥门威尼斯网址,no shut

(3卡塔尔练习OSPF多区域/单区域的计划和处理办法

  1. OSPF 多区域的剪切。

  2. OSPF 路由条目款项。

R2(config-if)#inter lo 1
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#ip ospf network point-to-point 
//不让它以为那是一条主机路由

履行拓扑图:

试验拓扑图:

R3(config)#inter s1/1
R3(config-if)#ip address 192.1.13.3 255.255.255.0
R3(config-if)#no shut

奥门威尼斯网址 1

奥门威尼斯网址 2

R3(config-if)#inter lo 1
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#ip ospf network point-to-poin
完毕安顿后在Odyssey1上测量检验两侧的连通性

实验拓扑图

尝试拓扑图

2、启用OSPF协议
R1(config)#router ospf ?
  <1-65535>  Process ID
R1(config)#router ospf 100
手工业钦点ROUTE-ID
R1(config-router)#router-id 1.1.1.1
点名区域

实施步骤

实验名称:OSPF的布局

R1(config-router)#network 192.1.12.0 0.0.0.255 ?
  area  Set the OSPF area ID
R1(config-router)#network 192.1.12.0 0.0.0.255 a 0
R1(config-router)#network 192.1.13.0 0.0.0.255 a 0
R1(config-router)#network 1.1.1.1 0.0.0.0 a 0

(1卡塔尔国 配置PC机.路由器.服务器的IP地址

尝试指标:

R2(config)#router ospf 100   //可以不生龙活虎制
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.1.12.0 0.0.0.255 a 0
R2(config-router)#network 2.2.2.0 0.0.0.255 a 1

R0

  1. 落实全网的互通。

  2. 通过退换优先级来兑现区别路由的转会。

R3(config)#router ospf 100
R3(config-router)#router-id 3.3.3.
R3(config-router)#network 192.1.13.0 0.0.0.255 a 0
R3(config-router)#network 3.3.3.0 0.0.0.255 a 2

R0>enable

试行宗旨:

3、查看邻居关系
R1#show ip ospf neighbor
4、查看路由表
R1#show ip route

R0#configure terminal.

  1. OSPF 多区域的细分。

  2. OSPF 路由条目款项。

5、在奥迪Q51上PING下区域1的环回地址(2.2.2.2卡塔 尔(阿拉伯语:قطر‎,可以通
PING区域2(3.3.3.3卡塔 尔(英语:State of Qatar),也足以通
6、能够查看数据库
R1#show ip ospf database
7、多少个OSPF常用命令
R1#show ip ospf ?
show ip ospf border-routers (查看路由器的角色等卡塔 尔(英语:State of Qatar)
R1#show ip ospf(查看基本新闻,比如进度号卡塔 尔(阿拉伯语:قطر‎
R1#show ip protocols(查看运转的协议卡塔 尔(阿拉伯语:قطر‎

R0(config)#interface FastEthernet0/0

推行拓扑图:

R0(config-if)#ip address 10.0.1.254 255.255.255.0

实验步骤:

R0(config-if)#no shutdown

R1:

R0(config-if)#exit

Router(config)#hostname R1

R0(config)#interface FastEthernet0/1

R1(config)#interface f0/1

R0(config-if)#ip address 10.0.2.254 255.255.255.0

R1(config)#clock rate 64000

R0(config-if)#no shutdown

R1(config-if)#ip address 10.0.1.254 255.255.255.0

R0(config-if)#exit

R1(config-if)#no shutdown

R0(config)#interface Serial1/0

R2:

R0(config-if)#ip address 30.0.0.1 255.255.255.0

R2(config)#interface s1/1

R0(config-if)#clock rate 64000

R2(config)#clock rate 64000

R0(config-if)#no shutdown

R2(config-if)#ip address 30.0.0.2 255.255.255.0

R1

R2(config-if)#no shutdown

R1>enable

R3:

R1#configure terminal

R3(config)#interface f0/0

R1(config)#interface FastEthernet0/0

R3(config-if)#ip address 50.0.0.254 255.255.255.0

R1(config-if)#ip address 20.0.0.254 255.255.255.0

R3(config-if)#no shutdown

R1(config-if)#no shutdown

R1

R1(config-if)#exit

R1(config)#router ospf

R1(config)#interface Serial1/0

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config-if)#ip address 40.0.0.1 255.255.255.0

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R1(config-if)#clock rate 64000

R1(config-router)#network 30.0.0.0 0.0.0.255 area 1

R1(config-if)#no shutdown

R2:

R1(config-if)#exit

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config)#interface Serial1/1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R1(config-if)#ip address 30.0.0.2 255.255.255.0

R2(config-router)#network 30.0.0.0 0.0.0.255 area 1

R1(config-if)#clock rate 64000

R2(config-router)#network 20.0.0.0 0.0.0.255 area 2

R1(config-if)#no shutdown

R2(config-router)#network 40.0.0.0 0.0.0.255 area 3

R2

R2(config-router)#network 50.0.0.0 0.0.0.255 area 3

R2>enable

R3:

R2#configure terminal

R3(config-router)#network 40.0.0.0 0.0.0.255 area 3

R2(config)#interface FastEthernet0/0

R3(config-router)#network 50.0.0.0 0.0.0.255 area 3

R2(config-if)#ip address 50.0.0.254 255.255.255.0

R3(config-router)#exit

R2(config-if)#no shutdown

R3#show ip route

R2(config-if)#exit

个人计算:

R2(config)#interface Serial1/1

  1. 率先ospf进度号两侧要意气风发致;

R2(config-if)#ip address 40.0.0.2 255.255.255.0

实施名称:OSPF的配备

R2(config-if)#clock rate 64000

尝试指标:

R2(config-if)#no shutdown

  1. 落到实处全网的互通。

  2. 透过改换优先级来兑现不相同路由的转速。

(2卡塔尔 OPSF的敞开和装置区域发表互联网

实施主题:

R0

  1. OSPF 多区域的分开。

  2. OSPF 路由条目款项。

R0>enable

实验拓扑图:

R0#configure terminal

施行步骤:

R0(config)#router ospf 12200

R1:

R0(config-router)#net 10.0.1.0 0.0.0.255 area 1

Router(config)#hostname R1

R0(config-router)#net 10.0.2.0 0.0.0.255 area 1

R1(config)#interface f0/1

R0(config-router)#net 30.0.0.0 0.0.0.255 area 1

R1(config)#clock rate 64000

R1

R1(config-if)#ip address 10.0.1.254 255.255.255.0

R1>enable

R1(config-if)#no shutdown

R1#configure terminal

R2:

R1(config)#router ospf 12200

R2(config)#interface s1/1

R1(config-router)#net 30.0.0.0 0.0.0.255 area 1

R2(config)#clock rate 64000

R1(config-router)#net 20.0.0.0 0.0.0.255 area 0

R2(config-if)#ip address 30.0.0.2 255.255.255.0

R1(config-router)#net 40.0.0.0 0.0.0.255 area 2

R2(config-if)#no shutdown

R2

R3:

R2>enable

R3(config)#interface f0/0

R2#configure terminal

R3(config-if)#ip address 50.0.0.254 255.255.255.0

R2(config)#router ospf 12200

R3(config-if)#no shutdown

R2(config-router)#net 40.0.0.0 0.0.0.255 area 2

R1

R2(config-router)#net 50.0.0.0 0.0.0.255 area 2

R1(config)#router ospf

实验结果:

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

PC>ping 50.0.0.1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

Pinging 50.0.0.1 with 32 bytes of data:

R1(config-router)#network 30.0.0.0 0.0.0.255 area 1

Reply from 50.0.0.1: bytes=32 time=9ms TTL=125

R2:

Reply from 50.0.0.1: bytes=32 time=2ms TTL=125

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

Reply from 50.0.0.1: bytes=32 time=10ms TTL=125

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

Reply from 50.0.0.1: bytes=32 time=2ms TTL=125

R2(config-router)#network 30.0.0.0 0.0.0.255 area 1

Ping statistics for 50.0.0.1:

R2(config-router)#network 20.0.0.0 0.0.0.255 area 2

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

R2(config-router)#network 40.0.0.0 0.0.0.255 area 3

Approximate round trip times in milli-seconds:

R2(config-router)#network 50.0.0.0 0.0.0.255 area 3

Minimum = 2ms, Maximum = 10ms, Average = 5ms

R3:

设置OSPF左券有以下优点

R3(config-router)#network 40.0.0.0 0.0.0.255 area 3

(1卡塔尔 可完毕全网通的通讯同一时间可因此转移优先级以致开支值改良路由路线

R3(config-router)#network 50.0.0.0 0.0.0.255 area 3

(2卡塔 尔(阿拉伯语:قطر‎ 幸免骨干区域压力过大 变成负载分担

R3(config-router)#exit

(3卡塔尔国 各种网络有温馨的区域减少了域内种种路由器的压力

R3#show ip route

个体计算:

  1. 先是ospf进度号两侧要生龙活虎律;

  2. 两边接口的地址要在同一网段;

  3. 发表网段时要注意带反掩码进行相称,后边跟上区域号;

试验步骤:

R1:

Router(config)#hostname R1

R1(config)#interface f0/1

R1(config)#clock rate 64000

R1(config-if)#ip address 10.0.1.254 255.255.255.0

R1(config-if)#no shutdown

R2:

R2(config)#interface s1/1

R2(config)#clock rate 64000

R2(config-if)#ip address 30.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R3:

R3(config)#interface f0/0

R3(config-if)#ip address 50.0.0.254 255.255.255.0

R3(config-if)#no shutdown

R1

R1(config)#router ospf

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R1(config-router)#network 30.0.0.0 0.0.0.255 area 1

R2:

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R2(config-router)#network 30.0.0.0 0.0.0.255 area 1

R2(config-router)#network 20.0.0.0 0.0.0.255 area 2

R2(config-router)#network 40.0.0.0 0.0.0.255 area 3

R2(config-router)#network 50.0.0.0 0.0.0.255 area 3

R3:

R3(config-router)#network 40.0.0.0 0.0.0.255 area 3

R3(config-router)#network 50.0.0.0 0.0.0.255 area 3

R3(config-router)#exit

R3#show ip route

个人总括:

  1. 首先ospf进度号两侧要风流浪漫律;

  2. 两侧接口的地点要在同一网段;

  3. 公布网段时要留神带反掩码实行匹配,前面跟上区域号

发表评论

电子邮件地址不会被公开。 必填项已用*标注